Back to overview
Degraded

Images not loading

Feb 25, 2026 at 3:18am UTC
Affected services
Images (Jetpack CDN)

Resolved
Feb 25, 2026 at 4:25am UTC

Resolved
This issue has now been resolved

Updated
Feb 25, 2026 at 4:15am UTC

Monitoring
We have implemented a fix and are now monitoring the results

Updated
Feb 25, 2026 at 3:45am UTC

We have disconnected the jetpack cdn temporarily while we investigate

Created
Feb 25, 2026 at 3:18am UTC

There is currently an issue when connecting the Jetpack site accelerator to the NZ1 server causing some images to not show on uncached pages