Back to overview
Maintenance

Windows Server Updates

Oct 29 at 01:30pm NZDT  –  Oct 29 at 02:20pm NZDT
Affected services
Server Accessibility
studio.coolio.website
switchboard.coolio.website

Resolved
Oct 29 at 02:20pm NZDT

All updates on the nz4 server have been completed.
All affected services should now be online:
- archives.coolio.website
- **switchboard.coolio.website

- studio.coolio.website*

All services should now be back online and fully operational.
If you encounter any issues it may be due to a docker container restarting.

Updated
Oct 29 at 01:44pm NZDT

The server nz4 is beginning updates. All services have been or will be shut down, this includes:
- archives.coolio.website
- switchboard.coolio.website
- studio.coolio.website

This server host some core services, so users may experience some errors accessing some parts of our websites.
During this time, these website will be down affecting redirects to other websites and other services.
Maintenance is expected to take about an hour, but the window may be extended if we encounter issues restarting our docker services.

Created
Oct 29 at 01:30pm NZDT

ON Wednesday 29 October we will be performing updates on our main Windows server.
During the maintenance period, some services will be down:
- switchboard.coolio.website - Handles redirects and some background services (this will cause many links and redirects to be unavailable. Uses 1 Docker service, Redis Object Cache)
- archives.coolio.website - Archive browser (fully Docker based service)
- studio.coolio.website - Studio site (uses 1 Docker service, Redis Object Cache)

This server uses Docker for all its services. In recent updates, we have observed that Docker can take up to an hour to come back online fully. This may cause intermittent outages for the affected website even after the update has been completed.

All websites should be fully operational after the maintenance window has closed. If anything goes wrong, the window may be extended and updates will be provided.